NOTE: THIS WEBSITE IS LEFT LIVE FOR ARCHIVE PURPOSES, BUT PDF::WRITER HAS BEEN DISCONTINUED AS OF APRIL 15th, 2010. PLEASE USE ITS SPIRITUAL SUCCESSOR, PRAWN INSTEAD. IF YOU ABSOLUTELY MUST USE PDF::WRITER, THE FINAL LATEST OFFICIAL CODE IS ON GITHUB HERE., BUT IS COMPLETELY UNSUPPORTED. IF YOU HAVE QUESTIONS, FEEL FREE TO CONTACT US ON THE PRAWN MAILING LIST.

Introduction

PDF::Writer for Ruby provides the ability to create PDF documents using only native Ruby libraries. There are several demo programs available in the demo/ directory. The canonical documentation for PDF::Writer is the 95-page manual, manual.pdf, generated using bin/techbook (just techbook for RubyGem users) and the manual file manual.pwd.

Development for PDF::Writer is hosted on RubyForge in the Ruby PDF Tools project.


Downloading

PDF::Writer 1.1.2 may be downloaded from the release page on the Ruby PDF Tools project.

Installation

PDF::Writer requires both Transaction::Simple 1.3.0 or later and color-tools 1.3.0 or later. Once these packages are installed, PDF::Writer can be installed with:

% ruby setup.rb

Alternatively, you can use the RubyGems version of PDF::Writer available as pdf-writer-1.1.2.gem from the usual sources. The gem knows its dependencies on Transaction::Simple and color-tools and offers to install them.

If you are using the RubyGems version of PDF::Writer, it is recommended that you download the demo programs from the RubyForge site for PDF::Writer.